jump to navigation

Installing FXRuby on Ubuntu June 15, 2009

Posted by ModelR in Everything LINUX.
Tags: ,
trackback

Also see this site: http://ubuntuforums.org/showthread.php?t=31532

If you plan on installing FXRuby on Ubuntu you will have to make sure a few packages are installed, or else the install will error out.

Here is one error that I ran into while trying to install:

extconf.rb:4:in 'require':no such file to load -- mkmf (LoadError)

What fixed this error was an install of ruby1.8-dev

Here is another error that I got:

/usr/bin/ld: cannot find -lXrandr

The fix for this is to install libxrandr-dev

So here are the packages that are required to get FXRuby (the version I installed was FXRuby-1.6.19 on Ubuntu 9.04 Jaunty)

ruby
libfox-1.6-dev
ruby1.8-dev
libxrandr-dev

Advertisements

Comments»

No comments yet — be the first.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: